时钟事件执行时间超出时钟周期问题解释

时钟组件 作为定时器 系统会在设定时间发送 WM_TIMER 消息给消息队列,因为事件处理函数和窗口回调函数都是同线程, 在一个消息未处理完返回之前是不能处理其他事件消息的,也就是一个时钟事件函数未执行完返回之前,系统是不会发送下一个 WM_TIMER 消息到消息队列中的,所以第二个WM_TIMER消息也就是会被忽略掉。

将时钟周期设置为500

1.下面这个例子你会发现 a 和b是同步的数值是相等的就是这个道理

1
2
3
4
5
6
7
8
.局部变量 a, 整数型, 静态
.局部变量 b, 整数型, 静态

a = a + 1
调试输出 (“a”, a)
延时 (1000)
b = b + 1
调试输出 (“b”, b)

2.第二个例子很有意思,你会发现程序一直在输出a ,而没有输出b,呵呵,你来猜猜是什么原因?

1
2
3
4
5
6
7
8
9
.局部变量 a, 整数型, 静态  
.局部变量 b, 整数型, 静态


a = a + 1
调试输出 (“a”, a)
延迟 (1000)
b = b + 1
调试输出 (“b”, b)

第二个例子 和第一个例子的区别是把延时()换成了延迟(),想来看看这两个命令的作用和区别,他们的区别一个是相当于暂停当前线程向下执行,等待设定长时间后在向下执行,但并不处理事件消息;

另一个是在等待中并且处理事件消息。那么为什么会出现这样的结果呢,首先来看一下延迟()命令 他是在等待中处理消息队列中未决的消息,那么WM_TEMER也作为一个消息队列中的消息,所以延迟()

当然责无旁贷需要处理掉,那么他是怎么处理的呢,无非是需要用到 PeekMessage (lpMsg, 0, 0, 0,PM_REMOVE) TranslateMessage (lpMsg) DispatchMessage (lpMsg) 自然是会在消息从消息队列中删除掉,也就是给了程序一个假象,表示上一次WM_TIMER消息已经处理完可以接收下一个,延迟()命令执行了1000毫秒完毕以后 正常该继续执行 b=b+1 并 调试输出 () 结果 ,可延迟()还没有执行完毕,因为在他执行的过程当中新的WM_TIMER 又来了,这个时候程序会怎么走呢?当延迟()命令还在执行当中,他会把进程未决的消息先依次处理,而在这期间收到的WM_TIMER都会被得到处理并执行,而每次延迟()命令会是这样的遭遇,于是乎就有了这样的结果,那么会这样一个问题,延迟()命令下面的代码会不会被执行呢?答案是肯定的,可他永远没有机会被执行,除非延迟()命令成功执行完毕,可他永远不会执行完毕。在一个因为只压栈不弹栈,执行一会程序就会出错,栈溢出。。。。程序崩溃告终。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
.版本 2
.支持库 spec


.子程序 __启动窗口_创建完毕


时钟1.时钟周期 = 1 ' 为了加快这里设置为1


.子程序 _时钟1_周期事件
.局部变量 a, 整数型, 静态
.局部变量 b, 整数型, 静态


a = a + 1
延迟 (5000)
b = b + 1
信息框 (a + b, 0, )
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×